package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)<img src=\".+?\/PIAimages\/(.+)\"`)
var str = `<img src="www.ikea.com/ms/img/header/logo.gif" >
<img src="www.ikea.com/ms/ru_RU/img/ads/askanna.jpg" >
<img src="www.ikea.com/ms/img/header/main_menu_shadow.gif" >
<img src="www.ikea.com/ms/media/seorange/20153/20151_dica04a..." >
<img src="www.ikea.com/PIAimages/0322782_PE516321_S3.JPG" >
<img src="www.ikea.com/PIAimages/0355650_PE547817_S3.JPG" >
www.ikea.com/PIAimages/0292760_PE425390_S3.JPG" >
www.ikea.com/PIAimages/0325067_PE523174_S3.JPG" >`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}