re = /<img src=\".+?\/PIAimages\/(.+)\"/i
str = '<img src="www.ikea.com/ms/img/header/logo.gif" >
<img src="www.ikea.com/ms/ru_RU/img/ads/askanna.jpg" >
<img src="www.ikea.com/ms/img/header/main_menu_shadow.gif" >
<img src="www.ikea.com/ms/media/seorange/20153/20151_dica04a..." >
<img src="www.ikea.com/PIAimages/0322782_PE516321_S3.JPG" >
<img src="www.ikea.com/PIAimages/0355650_PE547817_S3.JPG" >
www.ikea.com/PIAimages/0292760_PE425390_S3.JPG" >
www.ikea.com/PIAimages/0325067_PE523174_S3.JPG" >'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end