# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<img src=\".+?\/PIAimages\/(.+)\""
test_str = ("<img src=\"www.ikea.com/ms/img/header/logo.gif\" >\n"
"<img src=\"www.ikea.com/ms/ru_RU/img/ads/askanna.jpg\" >\n"
"<img src=\"www.ikea.com/ms/img/header/main_menu_shadow.gif\" >\n"
"<img src=\"www.ikea.com/ms/media/seorange/20153/20151_dica04a...\" >\n"
"<img src=\"www.ikea.com/PIAimages/0322782_PE516321_S3.JPG\" >\n"
"<img src=\"www.ikea.com/PIAimages/0355650_PE547817_S3.JPG\" >\n"
"www.ikea.com/PIAimages/0292760_PE425390_S3.JPG\" >\n"
"www.ikea.com/PIAimages/0325067_PE523174_S3.JPG\" >")
matches = re.finditer(regex, test_str, re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.