use strict;
my $str = '<img src="www.ikea.com/ms/img/header/logo.gif" >
<img src="www.ikea.com/ms/ru_RU/img/ads/askanna.jpg" >
<img src="www.ikea.com/ms/img/header/main_menu_shadow.gif" >
<img src="www.ikea.com/ms/media/seorange/20153/20151_dica04a..." >
<img src="www.ikea.com/PIAimages/0322782_PE516321_S3.JPG" >
<img src="www.ikea.com/PIAimages/0355650_PE547817_S3.JPG" >
www.ikea.com/PIAimages/0292760_PE425390_S3.JPG" >
www.ikea.com/PIAimages/0325067_PE523174_S3.JPG" >';
my $regex = qr/<img src=\".+?\/PIAimages\/(.+)\"/ip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}