using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<img src=\"".+?\/PIAimages\/(.+)\""";
string input = @"<img src=""www.ikea.com/ms/img/header/logo.gif"" >
<img src=""www.ikea.com/ms/ru_RU/img/ads/askanna.jpg"" >
<img src=""www.ikea.com/ms/img/header/main_menu_shadow.gif"" >
<img src=""www.ikea.com/ms/media/seorange/20153/20151_dica04a..."" >
<img src=""www.ikea.com/PIAimages/0322782_PE516321_S3.JPG"" >
<img src=""www.ikea.com/PIAimages/0355650_PE547817_S3.JPG"" >
www.ikea.com/PIAimages/0292760_PE425390_S3.JPG"" >
www.ikea.com/PIAimages/0325067_PE523174_S3.JPG"" >";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}