import Foundation
let pattern = #"<img src=\".+?\/PIAimages\/(.+)\""#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"""
<img src="www.ikea.com/ms/img/header/logo.gif" >
<img src="www.ikea.com/ms/ru_RU/img/ads/askanna.jpg" >
<img src="www.ikea.com/ms/img/header/main_menu_shadow.gif" >
<img src="www.ikea.com/ms/media/seorange/20153/20151_dica04a..." >
<img src="www.ikea.com/PIAimages/0322782_PE516321_S3.JPG" >
<img src="www.ikea.com/PIAimages/0355650_PE547817_S3.JPG" >
www.ikea.com/PIAimages/0292760_PE425390_S3.JPG" >
www.ikea.com/PIAimages/0325067_PE523174_S3.JPG" >
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)