import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<img src=\\\".+?\\/PIAimages\\/(.+)\\\"";
final String string = "<img src=\"www.ikea.com/ms/img/header/logo.gif\" >\n"
+ "<img src=\"www.ikea.com/ms/ru_RU/img/ads/askanna.jpg\" >\n"
+ "<img src=\"www.ikea.com/ms/img/header/main_menu_shadow.gif\" >\n"
+ "<img src=\"www.ikea.com/ms/media/seorange/20153/20151_dica04a...\" >\n"
+ "<img src=\"www.ikea.com/PIAimages/0322782_PE516321_S3.JPG\" >\n"
+ "<img src=\"www.ikea.com/PIAimages/0355650_PE547817_S3.JPG\" >\n"
+ "www.ikea.com/PIAimages/0292760_PE425390_S3.JPG\" >\n"
+ "www.ikea.com/PIAimages/0325067_PE523174_S3.JPG\" >";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}