using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<img.+?src=[\""'](.+?)[\""']>";
string substitution = @"ciao";
string input = @"Lorem ipsum dolor sit amet <img src=""https://pbs.twimg.com/profile_images/1075946974354886657/q-CYuf8L.jpg""> Sociis natoque penatibus et magnis dis parturient montes, nascetur ridiculus mus<img src=""https://pbs.twimg.com/profile_images/1075946974354886657/q-CYuf8L.jpg"">.
";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}