// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"<img.+?src=[\"'](.+?)[\"']>"#).unwrap();
let string = "Lorem ipsum dolor sit amet <img src=\"https://pbs.twimg.com/profile_images/1075946974354886657/q-CYuf8L.jpg\"> Sociis natoque penatibus et magnis dis parturient montes, nascetur ridiculus mus<img src=\"https://pbs.twimg.com/profile_images/1075946974354886657/q-CYuf8L.jpg\">.
";
let substitution = "ciao";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}