import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<img.+?src=[\\\"'](.+?)[\\\"']>";
final String string = "Lorem ipsum dolor sit amet <img src=\"https://pbs.twimg.com/profile_images/1075946974354886657/q-CYuf8L.jpg\"> Sociis natoque penatibus et magnis dis parturient montes, nascetur ridiculus mus<img src=\"https://pbs.twimg.com/profile_images/1075946974354886657/q-CYuf8L.jpg\">.\n";
final String subst = "ciao";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}