re = /<img.+?src=[\"'](.+?)[\"']>/
str = 'Lorem ipsum dolor sit amet <img src="https://pbs.twimg.com/profile_images/1075946974354886657/q-CYuf8L.jpg"> Sociis natoque penatibus et magnis dis parturient montes, nascetur ridiculus mus<img src="https://pbs.twimg.com/profile_images/1075946974354886657/q-CYuf8L.jpg">.
'
subst = 'ciao'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result