package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<img.+?src=[\"'](.+?)[\"']>`)
var str = `Lorem ipsum dolor sit amet <img src="https://pbs.twimg.com/profile_images/1075946974354886657/q-CYuf8L.jpg"> Sociis natoque penatibus et magnis dis parturient montes, nascetur ridiculus mus<img src="https://pbs.twimg.com/profile_images/1075946974354886657/q-CYuf8L.jpg">.
`
var substitution = "ciao"
fmt.Println(re.ReplaceAllString(str, substitution))
}