use strict;
my $str = 'Lorem ipsum dolor sit amet <img src="https://pbs.twimg.com/profile_images/1075946974354886657/q-CYuf8L.jpg"> Sociis natoque penatibus et magnis dis parturient montes, nascetur ridiculus mus<img src="https://pbs.twimg.com/profile_images/1075946974354886657/q-CYuf8L.jpg">.
';
my $regex = qr/<img.+?src=[\"'](.+?)[\"']>/p;
my $subst = 'ciao';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";