const regex = new RegExp('<img.+?src=[\\"\\'](.+?)[\\"\\']>', 'g')
const str = `Lorem ipsum dolor sit amet <img src="https://pbs.twimg.com/profile_images/1075946974354886657/q-CYuf8L.jpg"> Sociis natoque penatibus et magnis dis parturient montes, nascetur ridiculus mus<img src="https://pbs.twimg.com/profile_images/1075946974354886657/q-CYuf8L.jpg">.
`;
const subst = `ciao`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);