# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<img.+?src=[\"'](.+?)[\"']>"
test_str = ("Lorem ipsum dolor sit amet <img src=\"https://pbs.twimg.com/profile_images/1075946974354886657/q-CYuf8L.jpg\"> Sociis natoque penatibus et magnis dis parturient montes, nascetur ridiculus mus<img src=\"https://pbs.twimg.com/profile_images/1075946974354886657/q-CYuf8L.jpg\">.\n")
subst = "ciao"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.