# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?m)(?|(^[^.\n]*\.)|()\.+)/$1/g;t' <<< "59.343.43.23
817. ..
.343.43.23
"