package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?|(^[^.\n]*\.)|()\.+)`)
var str = `59.343.43.23
817. ..
.343.43.23
`
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}