$re = '/(?m)(?|(^[^.\n]*\.)|()\.+)/';
$str = '59.343.43.23
817. ..
.343.43.23
';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;