using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?m)(?|(^[^.\n]*\.)|()\.+)";
string substitution = @"$1";
string input = @"59.343.43.23
817. ..
.343.43.23
";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}