#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?|(^[^.\n]*\.)|()\.+)"
Local $sString = "59.343.43.23" & @CRLF & _
" 817. .. " & @CRLF & _
".343.43.23" & @CRLF & _
"" & @CRLF & _
""
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)