re = /(?m)(?|(^[^.\n]*\.)|()\.+)/
str = '59.343.43.23
817. ..
.343.43.23
'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result