use strict;
my $str = '59.343.43.23
817. ..
.343.43.23
';
my $regex = qr/(?m)(?|(^[^.\n]*\.)|()\.+)/p;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";