import Foundation
let pattern = #"(?m)(?|(^[^.\n]*\.)|()\.+)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
59.343.43.23
817. ..
.343.43.23
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)