const regex = /(?m)(?|(^[^.\n]*\.)|()\.+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?m)(?|(^[^.\\n]*\\.)|()\\.+)', 'g')
const str = `59.343.43.23
817. ..
.343.43.23
`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);