#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^"(?:\\(?:["\\\/bfnrt]|u[\da-fA-F]{8})|[^"\\])*"$"
Local $sString = "\uff009ea1" & @CRLF & _
"\t" & @CRLF & _
"\\" & @CRLF & _
"\b" & @CRLF & _
"\uff009ea1\t\\\b" & @CRLF & _
"\uff009ea1\\\b" & @CRLF & _
""Hello there, 123 !@&^#%! what???''"" & @CRLF & _
""Hello there 123 what"" & @CRLF & _
""Hello there, 123 !@&\t\\\b^#%! what???''"" & @CRLF & _
""Hello there \uff009ea1\t\\\b 123 what""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")