import Foundation
let pattern = #"^"(?:\\(?:["\\\/bfnrt]|u[\da-fA-F]{8})|[^"\\])*"$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
\uff009ea1
\t
\\
\b
\uff009ea1\t\\\b
\uff009ea1\\\b
"Hello there, 123 !@&^#%! what???''"
"Hello there 123 what"
"Hello there, 123 !@&\t\\\b^#%! what???''"
"Hello there \uff009ea1\t\\\b 123 what"
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)