package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^"(?:\\(?:["\\\/bfnrt]|u[\da-fA-F]{8})|[^"\\])*"$`)
var str = `\uff009ea1
\t
\\
\b
\uff009ea1\t\\\b
\uff009ea1\\\b
"Hello there, 123 !@&^#%! what???''"
"Hello there 123 what"
"Hello there, 123 !@&\t\\\b^#%! what???''"
"Hello there \uff009ea1\t\\\b 123 what"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}