use strict;
my $str = '\\uff009ea1
\\t
\\\\
\\b
\\uff009ea1\\t\\\\\\b
\\uff009ea1\\\\\\b
"Hello there, 123 !@&^#%! what???\'\'"
"Hello there 123 what"
"Hello there, 123 !@&\\t\\\\\\b^#%! what???\'\'"
"Hello there \\uff009ea1\\t\\\\\\b 123 what"';
my $regex = qr/^"(?:\\(?:["\\\/bfnrt]|u[\da-fA-F]{8})|[^"\\])*"$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}