$re = '/^"(?:\\\\(?:["\\\\\/bfnrt]|u[\da-fA-F]{8})|[^"\\\\])*"$/m';
$str = '\\uff009ea1
\\t
\\\\
\\b
\\uff009ea1\\t\\\\\\b
\\uff009ea1\\\\\\b
"Hello there, 123 !@&^#%! what???\'\'"
"Hello there 123 what"
"Hello there, 123 !@&\\t\\\\\\b^#%! what???\'\'"
"Hello there \\uff009ea1\\t\\\\\\b 123 what"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);