import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\"(?:\\\\(?:[\"\\\\\\/bfnrt]|u[\\da-fA-F]{8})|[^\"\\\\])*\"$";
final String string = "\\uff009ea1\n"
+ "\\t\n"
+ "\\\\\n"
+ "\\b\n"
+ "\\uff009ea1\\t\\\\\\b\n"
+ "\\uff009ea1\\\\\\b\n"
+ "\"Hello there, 123 !@&^#%! what???''\"\n"
+ "\"Hello there 123 what\"\n"
+ "\"Hello there, 123 !@&\\t\\\\\\b^#%! what???''\"\n"
+ "\"Hello there \\uff009ea1\\t\\\\\\b 123 what\"";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}