import re
regex = re.compile(r"^\"(?:\\(?:[\"\\\/bfnrt]|u[\da-fA-F]{8})|[^\"\\])*\"$", flags=re.MULTILINE)
test_str = ("\\uff009ea1\n"
"\\t\n"
"\\\\\n"
"\\b\n"
"\\uff009ea1\\t\\\\\\b\n"
"\\uff009ea1\\\\\\b\n"
"\"Hello there, 123 !@&^#%! what???''\"\n"
"\"Hello there 123 what\"\n"
"\"Hello there, 123 !@&\\t\\\\\\b^#%! what???''\"\n"
"\"Hello there \\uff009ea1\\t\\\\\\b 123 what\"")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")