# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\s+\bcc\b|\bcc\b\s+//gm;t' <<< "aaa1234 cc bbb1234 c1234 cc dd aacc cccc ccadf cc"