const regex = /\s+\bcc\b|\bcc\b\s+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\s+\\bcc\\b|\\bcc\\b\\s+', 'gm')
const str = `aaa1234 cc bbb1234 c1234 cc dd aacc cccc ccadf cc`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);