$re = '/\s+\bcc\b|\bcc\b\s+/m';
$str = 'aaa1234 cc bbb1234 c1234 cc dd aacc cccc ccadf cc';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;