// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\s+\bcc\b|\bcc\b\s+").unwrap();
let string = "aaa1234 cc bbb1234 c1234 cc dd aacc cccc ccadf cc";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}