use strict;
my $str = 'aaa1234 cc bbb1234 c1234 cc dd aacc cccc ccadf cc';
my $regex = qr/\s+\bcc\b|\bcc\b\s+/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";