import Foundation
let pattern = #"\s+\bcc\b|\bcc\b\s+"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"aaa1234 cc bbb1234 c1234 cc dd aacc cccc ccadf cc"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)