re = /\s+\bcc\b|\bcc\b\s+/m
str = 'aaa1234 cc bbb1234 c1234 cc dd aacc cccc ccadf cc'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result