#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\b(0x[\da-fA-F]+|[\d]+|0b[01]+)\b"
Local $sString = "1234 (decimal)" & @CRLF & _
"0x12CD (hex)" & @CRLF & _
"0x12cd (hex lowercase)" & @CRLF & _
"12CD (hex without the 0x prefix)" & @CRLF & _
"0b0010101011" & @CRLF & _
"0bh24j"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")