import re
regex = re.compile(r"\b(0x[\da-fA-F]+|[\d]+|0b[01]+)\b")
test_str = ("1234 (decimal)\n"
"0x12CD (hex)\n"
"0x12cd (hex lowercase)\n"
"12CD (hex without the 0x prefix)\n"
"0b0010101011\n"
"0bh24j")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")