const regex = /\b(0x[\da-fA-F]+|[\d]+|0b[01]+)\b/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(0x[\\da-fA-F]+|[\\d]+|0b[01]+)\\b', 'g')
const str = `1234 (decimal)
0x12CD (hex)
0x12cd (hex lowercase)
12CD (hex without the 0x prefix)
0b0010101011
0bh24j`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}