using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(0x[\da-fA-F]+|[\d]+|0b[01]+)\b";
string input = @"1234 (decimal)
0x12CD (hex)
0x12cd (hex lowercase)
12CD (hex without the 0x prefix)
0b0010101011
0bh24j";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}