use strict;
my $str = '1234 (decimal)
0x12CD (hex)
0x12cd (hex lowercase)
12CD (hex without the 0x prefix)
0b0010101011
0bh24j';
my $regex = qr/\b(0x[\da-fA-F]+|[\d]+|0b[01]+)\b/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}