import Foundation
let pattern = #"\b(0x[\da-fA-F]+|[\d]+|0b[01]+)\b"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
1234 (decimal)
0x12CD (hex)
0x12cd (hex lowercase)
12CD (hex without the 0x prefix)
0b0010101011
0bh24j
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)