#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[A-Z,a-z]{3}-[A-Z,a-z]{2}\d{2}-[A-Z,a-z]{3}-\d{3}|^[A-Z,a-z]{2}\d{2}-[A-Z,a-z]{3}-\d{3}$"
Local $sString = "FA12-BSE-008"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")