const regex = new RegExp('^[A-Z,a-z]{3}-[A-Z,a-z]{2}\\d{2}-[A-Z,a-z]{3}-\\d{3}|^[A-Z,a-z]{2}\\d{2}-[A-Z,a-z]{3}-\\d{3}$', 'm')
const str = `FA12-BSE-008`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}