use strict;
my $str = 'FA12-BSE-008';
my $regex = qr/^[A-Z,a-z]{3}-[A-Z,a-z]{2}\d{2}-[A-Z,a-z]{3}-\d{3}|^[A-Z,a-z]{2}\d{2}-[A-Z,a-z]{3}-\d{3}$/mp;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}