re = /^[A-Z,a-z]{3}-[A-Z,a-z]{2}\d{2}-[A-Z,a-z]{3}-\d{3}|^[A-Z,a-z]{2}\d{2}-[A-Z,a-z]{3}-\d{3}$/m
str = 'FA12-BSE-008'
# Print the match result
str.match(re) do |match|
puts match.to_s
end