package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[A-Z,a-z]{3}-[A-Z,a-z]{2}\d{2}-[A-Z,a-z]{3}-\d{3}|^[A-Z,a-z]{2}\d{2}-[A-Z,a-z]{3}-\d{3}$`)
var str = `FA12-BSE-008`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}