import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[A-Z,a-z]{3}-[A-Z,a-z]{2}\\d{2}-[A-Z,a-z]{3}-\\d{3}|^[A-Z,a-z]{2}\\d{2}-[A-Z,a-z]{3}-\\d{3}$";
final String string = "FA12-BSE-008";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}